PDA

View Full Version : can't clear up cloudy water??



postunit
02-17-2003, 10:58 PM
I have been trying to clear up a cloudy (kinda white & foggy...looks OK from the front, but very apparent from the ends) 110 gallon tank for six weeks. I filled it January 1 and have had a few clear days, but they don't last long. I have done at least 3 water changes of 25-30%.

I have about 18 Africans juvy's in the tank. They were added a couple at a time over 5 weeks.

I also have a huge man-made stump decoration in the tank. The LFS said this wood was OK for my tank. PH 8.0, ammonia 0, nitrites 0. Any thoughts on getting my water clear or have I not given it enough time yet??

All help is greatly appreciated.

WorldNation
02-18-2003, 12:15 AM
its still new tank syndrom probably. some last from a month to 4. it should go away on its own soon. there are products out there that help prevent this though. i'll get a list tomorrow.

SGypsyMermaid
02-18-2003, 05:40 AM
it's a bacterial bloom...part of new tank syndrome. just keep a watch on your tank's parameters...it will go away.

postunit
02-18-2003, 06:54 AM
Thanks very much for your input. I've heard this response a couple times. It helps having it hammered home a couple times so I don't do something stupid with the new tank!!

Are 20% weekly water changes good at this stage??

SGypsyMermaid
02-18-2003, 09:49 AM
[quote:5aede0712b="postunit"]Thanks very much for your input. I've heard this response a couple times. It helps having it hammered home a couple times so I don't do something stupid with the new tank!!

Are 20% weekly water changes good at this stage??[/quote:5aede0712b]

i would say so. also, feed lightly, for about 2 more weeks to give the bacteria population some more time to stabilize.

matt1066
02-18-2003, 06:13 PM
Hi there,

You say it is a man-made stump, but then you said the lfs said the wood would be OK for your tank.

Man made stumps are made of inert resin not wood. If it is made of wood I would think that might be your problem, combined with an algae bloom.

Just a thought. :roll:

Matt

JB wind
03-04-2003, 09:47 PM
I just had your problem in my tank as well, cloudy since a month after i put a LFS bought chunk of driftwood. I took it out Monday and today the tank is crystal clear. I thought it was weird that my 75 was clear as a bell and my 40 which has been up 4 months longer than the 75 wasn't clear. the only thing different in the tanks was the driftwood in the 40. so good luck, maybe that is your problem as well